Satellite Layer Updates Delayed
Incident Report for AerisWeather
Resolved
Satellite imagery has restored and is running as expected.
Posted Apr 20, 2020 - 13:32 CDT
Monitoring
There is an issue with our upstream provider at NOAA/NWS for satellite data. We have contacted them and will continue to monitor.
Posted Apr 20, 2020 - 09:54 CDT
This incident affected: Aeris Maps Platform (AMP) (Satellite).